Basic Commands

Solaris | Windows

ls -l | dir (displays a listing of the contents of the current working directory)

vi | edit (runs an editor to modify the contents of a file)

rm | del (removes/deletes a file or files)

cp -r | xcopy (copys a file or directory to a specified location)

mkdir | mkdir (makes the specified directory)

rm -r | rmdir (removes a specified directory)

chmod | attrib (modifies the attributes/permissions of a file or directory)

cat | print (displays the contents of a specified file)

format | chkdsk (runs a utility that can check the status and operation of a drive)

pwd | chdir (lists the full path of your current working directory)

date | time, date (lists the current date and time)

ifconfig -a | ipconfig /all (displays all configured network interfaces)

cd | cd (change directories)

share | Computer Management (List shares currently enabled on the system)
————————————————————————————————

Utilities

prstat -a | Task manager (Lists details about active processes, CPU and RAM utilization)

/etc/path_to_inst, prtdiag -v | Device manager, winmsd (Contains information about locally connected hardware)

/var/adm/messages | Event Viewer (Contains application and system logs)

/etc/init.d/*, svcs, svcadm | Services (Check status, start and stop services)

pkginfo -l, pkgchk, pkgrm, pkgadd | add/remove programs (display, check, remove and add programs)

————————————————————————————————

Files

/etc/hosts, /etc/inet/ipnodes| c:\windows\system32\drivers\etc\hosts (IP and hostname resolution)

/etc/resolv.conf | TCP/IP properties for an interface (Contains IP address for Pri/Sec DNS servers)

/etc/defaultrouter | TCP/IP properties for an interface (Contains IP address for default gateway)

/etc/power.conf | Power Management (Control power save settings)

/etc/passwd | Computer Management (Lists users and group settings)

/etc/shadow | Registry entry (Contains encrypted password strings of configured users)

/etc/group | Computer Management (Lists configured user groups)

/etc/vfstab | Computer Management (Lists hard drive partitioning configuration)